Thread: Need help with charging problem

Reply to Thread
Results 1 to 9 of 9
  1. #1
    Viper Owner
    Join Date
    May 2003
    Location
    Chicagoland
    Posts
    34

    Default Need help with charging problem

    Hey guys.....I'm having a charging problem with my 96 GTS. I put a new battery in about 6 months ago and the alternator is charging/meter also reads 14 when car is running. But when i shut the car off for more than an hour the battery wont turn the starter more than a couple times. I put it on a jump for about 3 seconds and it starts right up..any ideas?

    Thanks in advance

  2. #2
    Enthusiast

    Join Date
    Oct 2000
    Location
    San Diego, CA. USA
    Posts
    3,410

    Default Re: Need help with charging problem

    Inspect the terminal connectors on the cables and clean them really well if you find they have a lot of buildup.

    If they look okay, pull the battery and and check each cell with a specific gravity checker. If one cell is really low compared to the rest, you have a dead cell.

  3. #3
    Viper Owner
    Join Date
    May 2003
    Location
    Chicagoland
    Posts
    34

    Default Re: Need help with charging problem

    Thanks a lot....ill try that tonight

  4. #4
    Viper Owner
    Join Date
    May 2003
    Location
    Chicagoland
    Posts
    34

    Default Re: Need help with charging problem

    Just took it apart....Sure enough...2 Bad cells. Ive never heard of this with a new battery though

    Thanks for the help

  5. #5
    Enthusiast

    Join Date
    Nov 2000
    Location
    NE Ohio
    Posts
    3,483

    Default Re: Need help with charging problem

    You might want to try a maintenance free battery and not have to worry about the fluid level.

  6. #6
    Viper Owner
    Join Date
    May 2003
    Location
    Chicagoland
    Posts
    34

    Default Re: Need help with charging problem

    Do any of you guys use OPTIMA batteries?..I think i might try that next

  7. #7
    Enthusiast

    Join Date
    Oct 2000
    Location
    San Diego, CA. USA
    Posts
    3,410

    Default Re: Need help with charging problem

    It's not unheard of to pull a new battery off the shelf and it has a bad cell. Also, if it was working fine for a few months before all this happened, you might want to have your alternator checked. Could be under or over charging the battery.

    As far as Optimas go, they seem to be the ticket, but they are still a acid type battery.

  8. #8
    Viper Owner
    Join Date
    Feb 2003
    Location
    San Francisco, CA
    Posts
    255

    Default Re: Need help with charging problem

    I got an Optima. Works great. Maintenance free and no worries about leaks.

    I also had some corrosion at the connection to the starter before. I cleaned the terminals at the starter and at the fusebox and everythings been fine ever since.

  9. #9
    Viper Owner
    Join Date
    May 2003
    Location
    Chicagoland
    Posts
    34

    Default Re: Need help with charging problem

    Can you give me the model# and type you used?

Similar Threads

  1. A/C Charging Procedure?
    By Ag's'95 in forum RT/10 and GTS Discussions
    Replies: 0
    Last Post: 08-08-2006, 10:16 PM
  2. A/C charging question.
    By Qualitywires.com in forum RT/10 and GTS Discussions
    Replies: 2
    Last Post: 06-13-2004, 12:16 PM
  3. Battery Charging
    By Mopar488 in forum RT/10 and GTS Discussions
    Replies: 7
    Last Post: 05-02-2004, 02:47 PM
  4. RT/10 Charging System
    By COILD in forum RT/10 and GTS Discussions
    Replies: 3
    Last Post: 01-04-2004, 11:18 AM
  5. Supercharging/turbo charging
    By glenn hofstetter in forum RT/10 and GTS Discussions
    Replies: 9
    Last Post: 05-02-2002, 06:21 PM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts