Thread: genIV ACR

Reply to Thread
Results 1 to 9 of 9
  1. #1
    Viper Owner
    Join Date
    Nov 2011
    Location
    Prince George BC Canada
    Posts
    296

    Default genIV ACR

    Noticing now with 3k km on the car, roll on power through 1-3 the front end is lifting a lot more than it did when it had less than 1k km. there is also a clunk left rear tower if the car hits a bit of a bump.
    Question: is it normal to have to make a preload adjustment when it's broken in?

  2. #2
    Viper Owner
    Join Date
    Jun 2008
    Location
    Bentonville, Arkansas
    Posts
    1,126

    Default Re: genIV ACR

    Have never experienced that with my 08 ACR.

  3. #3
    Viper Owner
    Join Date
    Mar 2009
    Location
    La Junta Colorado 81050
    Posts
    2,102

    Default Re: genIV ACR

    Sounds like you probably have an issue with the struts that will require replacement. I don't think you'll be able to 'adjust out' a noise, and with the car changing suspension angles that much (that you're noticing it like that), with that low of mileage, there is something wrong. Your car is new enough, it may be subject to warranty. May just be something loose (hopefully not)

  4. #4
    Viper Owner
    Join Date
    Aug 2008
    Location
    coral gables FL
    Posts
    264

    Default

    Not a problem that I have heard of or have on my 10 acr and not on my other viper. Get it checked out. Good luck.

  5. #5
    Enthusiast

    Join Date
    Jul 2009
    Location
    Cairo ,Egypt
    Posts
    382

    Default Re: genIV ACR

    i would get under it and have a look

  6. #6
    Viper Owner
    Join Date
    Nov 2011
    Location
    Prince George BC Canada
    Posts
    296

    Default

    Thanks for feedback, spoke with the dealership, going in Tuesday next week.

  7. #7
    Viper Owner
    Join Date
    May 2008
    Location
    Omaha, NE
    Posts
    3,514

    Default Re: genIV ACR

    You can look at the shock and see if it may have blown or is leaking.

    Bruce

  8. #8
    Viper Owner
    Join Date
    Nov 2011
    Location
    Prince George BC Canada
    Posts
    296

    Default

    Turns out there was an issue on the passenger side rear. The smaller spring had come out of place and was a little sideways :S ???
    Anyways no more noise and no more wheel stands when heavy on the throttle. )

  9. #9
    Enthusiast

    Join Date
    Jul 2009
    Location
    Cairo ,Egypt
    Posts
    382

    Default Re: genIV ACR

    good news , enjoy it .

Similar Threads

  1. Tunning a GenIV
    By M_viper in forum SRT10 and SRT10 Coupe Discussions
    Replies: 20
    Last Post: 02-17-2012, 11:24 AM
  2. O2 simms for GenIV
    By hightest in forum SRT10 and SRT10 Coupe Discussions
    Replies: 5
    Last Post: 08-31-2011, 06:29 PM
  3. GenIV Security
    By 70cuda in forum SRT10 and SRT10 Coupe Discussions
    Replies: 2
    Last Post: 06-10-2011, 07:22 AM
  4. stiffer shocks on GenIV
    By hightest in forum SRT10 and SRT10 Coupe Discussions
    Replies: 3
    Last Post: 09-10-2009, 08:49 AM
  5. GenIV Radiator Fan in a GenIII?
    By Shandon in forum SRT10 and SRT10 Coupe Discussions
    Replies: 5
    Last Post: 04-16-2009, 11:09 AM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts