Thread: No Crank sensor learned

Reply to Thread
Results 1 to 7 of 7
  1. #1

    Default No Crank sensor learned

    Took my 2014 viper GTS that i bought new 3 months ago to the dealer for a check engine light. The description for the diagnostic was "no crank sensor learned" and the car wouldn't start without a jump start either. Anyone got any info on this as i have had nothing but problems with my new viper. I had taken the car in 2 weeks ago for the same failure to start issue. Any ideas what could be causing this and is this issue severe enough to be worried about engine failure?

  2. #2
    VCA Legacy Member
    UT/AZ

    Join Date
    Sep 2010
    Location
    Idaho
    Posts
    3,569

    Default Re: No Crank sensor learned

    I don't see why it would indicate an engine failure. It's a sensor and I would look there first.

    What did they find the last time you took it in?

  3. #3
    Enthusiast

    Join Date
    Dec 2015
    Location
    Orwigsburg, PA
    Age
    35
    Posts
    95

    Default Re: No Crank sensor learned

    No service bulletins, no Star cases in Chrysler's system. Most probable causes are a bad crank sensor, wiring, PCM or a damaged tone ring on the crankshaft. I highly doubt the last item on the list.

  4. #4
    Enthusiast

    Join Date
    Aug 2005
    Location
    Chandler AZ
    Posts
    2,982

    Default Re: No Crank sensor learned

    Quote Originally Posted by Quarterhorse89 View Post
    Took my 2014 viper GTS that i bought new 3 months ago to the dealer for a check engine light. The description for the diagnostic was "no crank sensor learned" and the car wouldn't start without a jump start either.
    If those two symptoms are due to the same cause, then I'd suspect that the engine code is a spurious false code due to low voltage. If the battery was run down, then I wouldn't worry about a code like that if it didn't return.

    So then one would ask about why did the battery run down? There have been several threads asking this on several Gen V forums. One conjecture was that storing the key fob close to the car caused a drain on the car battery due to constant RF communication between the fob and the PCM. I never read any proof of that as being the cause though.

    If the car sat a long time before being sold to you, or the battery was allowed to fully discharge, or somehow went bad during its time at the dealership, that may be the cause of a bad battery.(or maybe it was just a weak battery from the manufacturer.) I would ask them to replace it under warranty. Low battery voltage can play strange games with the car's computer. This is a well known issue with older generation Vipers; so, maybe also with the newest generation. You really want to have a known good battery before troubleshooting weird electrical symptoms.

    _________________________________________________
    Jim – ‘02 GTS ACR gray/silver -- sold – ( enthusiastic custodian for 8 years )

  5. #5

    Default Re: No Crank sensor learned

    Well the first time i took it in they advised a sensor on the transmission which i found to be nonsense....one thing i do know is that i keep my keys inside my car at all times, so when i get it back i will take them inside the house and see what happens. They advised at the dealership that they had installed a new battery last time. What bothets me is that i bought this car new 3 months ago and its been at the dealer for a month total time getting serviced due to problems. Never had any problems like this with any of the vettes i owned, my last being a 2013 vert 427.

  6. #6
    VCA Member
    Gulf States

    broomrider's Avatar
    Join Date
    Jul 2015
    Location
    Louisiana
    Posts
    1,395

    Default Re: No Crank sensor learned

    I know this sounds crazy but have them change the batteries in your key fob as well. Sometimes when those get low, they can effect your car in weird ways
    My srt8 chrysler was giving me fits with not wanting to start and a host of other oddities. The batteries were changed all around, fobs, car etc. And it fixed things.
    Also, if it is a false code, drive it around for a bit before taking it in. Sometimes they will clear on their on. Just my thoughts

  7. #7

    Default Re: No Crank sensor learned

    Thanx for the input fellas, i'll keep u all posted in about 2 weeks. Thats probably how long itll be there.

Similar Threads

  1. crank sensor location anyone??
    By ulllose in forum SRT10 and SRT10 Coupe Discussions
    Replies: 14
    Last Post: 07-01-2011, 07:55 PM
  2. crank sensor position Q.
    By aboadnan in forum SRT10 and SRT10 Coupe Discussions
    Replies: 0
    Last Post: 12-04-2010, 02:28 AM
  3. Cam Sensor went out Now the CRANK SENSOR? WTF
    By jmillsUT28 in forum RT/10 and GTS Discussions
    Replies: 15
    Last Post: 06-16-2010, 08:54 AM
  4. anyone else have crank sensor replaced 08
    By 08viperviolet in forum SRT10 and SRT10 Coupe Discussions
    Replies: 2
    Last Post: 03-23-2010, 02:20 PM
  5. Fuel line check valves shipping out... (no more crank, crank, crank)
    By Tom, F&L GoR in forum RT/10 and GTS Discussions
    Replies: 0
    Last Post: 04-05-2005, 08:02 AM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts