Thread: No dash or tail lights

Reply to Thread
Results 1 to 9 of 9
  1. #1
    VCA Member
    CO/NM

    Join Date
    Jan 2016
    Posts
    40

    Default No dash or tail lights

    Got my old Clifford alarm system removed so now my next issue. I don't have any dash lights, parking lights or taillights. Headlights, fog lights, interior dome(rear view mirror) lights all work. I checked the fuse box and all fuses are good. (The problem lights didn't work before I removed the 20 miles of the alarm wiring- in case you were wondering.....) Some old threads suggest the headlight switch is the problem. Before I spend $70 on a new one (local dealer says it is available-part # 56021898AB) does anyone have any other ideas????????Thanks.

  2. #2
    Viper Owner
    Join Date
    Dec 2000
    Location
    OH,USA
    Posts
    330

    Default Re: No dash or tail lights

    If all fuses are good, check the BCM( Body Control Module) connections by plugging them in and out a couple times. Chrysler is notorious for bad electrical connections. Also remove all fuses and relays and plug them in and out a couple times to make sure they are making good connections. It's possible it's a headlight switch!

  3. #3
    VCA Member
    CO/NM

    Join Date
    Jan 2016
    Posts
    40

    Default Re: No dash or tail lights

    Where is the body control module and what does it look like?

  4. #4
    Viper Owner
    Join Date
    Dec 2000
    Location
    OH,USA
    Posts
    330

    Default Re: No dash or tail lights

    What model/year Viper? It's a flat rectangular box under the dash that all the wires lead to with multiple connectors on it. Follow all the wire harnesses under the dash to find it.

  5. #5
    VCA Member
    CO/NM

    Join Date
    Jan 2016
    Posts
    40

    Default Re: No dash or tail lights

    It's a 94- thanks

  6. #6
    Enthusiast

    Join Date
    Aug 2005
    Location
    Chandler AZ
    Posts
    2,982

    Default Re: No dash or tail lights

    If he is talking about a Gen II, I'd verify that fuse 1 (in the passenger compartment block) does or does not have voltage on either side of the fuse. No voltage on both sides leads me to believe that it is the headlight switch. I am assuming that the brake lights work, and the side marker lights don't work. I took a look at the manual that happens to be sitting out on my workbench. I don't see the body control module in the circuit; but, the schematics are not easy to follow.

    edit: just saw the post that the OP is talking about a Gen I. Never mind my input above.

  7. #7
    Viper Owner
    Join Date
    Dec 2000
    Location
    OH,USA
    Posts
    330

    Default Re: No dash or tail lights

    Quote Originally Posted by AZTVR View Post
    If he is talking about a Gen II, I'd verify that fuse 1 (in the passenger compartment block) does or does not have voltage on either side of the fuse. No voltage on both sides leads me to believe that it is the headlight switch. I am assuming that the brake lights work, and the side marker lights don't work. I took a look at the manual that happens to be sitting out on my workbench. I don't see the body control module in the circuit; but, the schematics are not easy to follow.

    edit: just saw the post that the OP is talking about a Gen I. Never mind my input above.
    Your point is still valid. It could be the headlight switch and with several unrelated lights not working that flow through that it's probable, but they all feed out of the BCM and it could be a loose plug or corroded plug.

  8. #8
    VCA Member
    Midsouth

    Join Date
    Dec 2010
    Posts
    1

    Default Re: No dash or tail lights

    What was the fix for your instrument panel lights and tail light problem? I have same problem on a 1994 RT-10. I cannot find the fuse panel. The owner's manual says it is under the passenger's feet; however, that panel seems to have connectors but no fuses. Will appreciate your help.

  9. #9
    VCA Member
    CO/NM

    Join Date
    Jan 2016
    Posts
    40

    Default Re: No dash or tail lights

    It was the headlight switch- had melted a little bit sometime in the past and I was able to repair it. Call me at 719-276-1818 and we can talk about that and maybe other problems we share??????

Similar Threads

  1. SMOKED tail lights??
    By VIPER08 in forum SRT10 and SRT10 Coupe Discussions
    Replies: 48
    Last Post: 08-09-2013, 09:56 PM
  2. LED Tail lights ????
    By VIPER BAZ UK in forum RT/10 and GTS Discussions
    Replies: 51
    Last Post: 11-02-2012, 07:31 PM
  3. anyone know how to remove the tail lights and headlights?
    By agdetail in forum SRT10 and SRT10 Coupe Discussions
    Replies: 5
    Last Post: 08-31-2012, 07:19 AM
  4. And all I saw..... were tail lights today....Sad story.
    By Newport Viper in forum RT/10 and GTS Discussions
    Replies: 43
    Last Post: 06-14-2006, 10:55 AM
  5. "Altezza" tail lights on SRT? just a thought
    By Viperzilla in forum SRT10 and SRT10 Coupe Discussions
    Replies: 12
    Last Post: 08-23-2003, 09:49 AM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts