Thread: Smoke from O2 Sensors

Reply to Thread
Results 1 to 3 of 3
  1. #1

    Default Smoke from O2 Sensors

    Just finished installing my M&M Headers tonight (along with straight pipes again and she sounds like she should), fired the Viper up and noticed some smoke coming from under the hood. Obviously shut the car off, popped the hood, saw nothing.

    Take 2: Same story after about 2 minutes at idle. Noticed the smoke source coming from both upstream O2 Sensors (or maybe some residual whatever from the weld burning off?)

    Anybody else have this experience with new headers? Or have a theory on what's up?
    Thanks!

    -Nick

  2. #2

    Default Re: Smoke from O2 Sensors

    Any new exhaust stuff will have oil and grease on them that need to burn off. If its coming from the O2 bungs, they may be loose indicating an air leak.

  3. #3

    Default Re: Smoke from O2 Sensors

    Yup, a little bit more this morning. No more since, has to be residual oil

    Carry on

Similar Threads

  1. Smoke'in
    By EllowViper in forum RT/10 and GTS Discussions
    Replies: 8
    Last Post: 09-20-2006, 11:06 PM
  2. And I don't even smoke.....
    By SteveBCloud9 in forum SRT10 and SRT10 Coupe Discussions
    Replies: 7
    Last Post: 02-06-2006, 12:11 AM
  3. Engine Smoke
    By Viper Byte in forum RT/10 and GTS Discussions
    Replies: 5
    Last Post: 01-24-2006, 11:28 PM
  4. smoke 'em if you got 'em
    By LTHL-GRY in forum Sneaky Pete's Place
    Replies: 4
    Last Post: 04-11-2002, 05:07 PM
  5. Oh not more smoke!
    By Nadine UK GTS in forum RT/10 and GTS Discussions
    Replies: 5
    Last Post: 08-11-2001, 01:49 AM
Tags for this Thread

View Tag Cloud

Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts