Thread: (Almost) new Viper owner, saying hi

Reply to Thread
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 31 to 60 of 65
  1. #31
    VCA Member
    Midsouth

    2001-V10 Power Nut's Avatar
    Join Date
    Jun 2006
    Location
    Florida
    Posts
    938

    Default Re: (Almost) new Viper owner, saying hi

    I have purchased from Parts Rack before, they are good, don't know anything about viper store
    2001-ACR, 2001 RT-10, 2008 SRT-10, 2013 GTS

  2. #32
    Viper Owner
    Join Date
    Dec 2006
    Location
    Lancaster, PA
    Posts
    1,348

    Default Re: (Almost) new Viper owner, saying hi

    Viper store seems over priced. I would stick with JonB and Roe Racing.

  3. #33

    Default Re: (Almost) new Viper owner, saying hi

    Thanks, guys, appreciate the input.

  4. #34

    Default Re: (Almost) new Viper owner, saying hi

    So, any fellow Viper owners in Maine or New England?

  5. #35

    Default Re: (Almost) new Viper owner, saying hi

    Well, I *finally* took delivery today! Pictures to come soon. New question: while maneuvering it into my garage, an upwards orange arrow lit up on my central display...overheat warning?

  6. #36

    Default Re: (Almost) new Viper owner, saying hi

    1-4 shift skip i think.

  7. #37

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by TalonTSi90 View Post
    1-4 shift skip i think.
    Hmm...I was hardly moving the first time, and the second time I was sitting completely still. I was going to look it up in owner's manual, but it hasn't gotten to me yet.

  8. #38

    Default Re: (Almost) new Viper owner, saying hi

    Been 24 hours, no pics yet?

  9. #39

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by TalonTSi90 View Post
    Been 24 hours, no pics yet?
    I've had my hands full, but yes, I did snap one after first pulling it into the garage--let's see if this works...

    Viper.jpg

  10. #40

    Default Re: (Almost) new Viper owner, saying hi

    New question: does anyone else have to crush their clutch against the floor in order to get their Viper to start?

    When I tried starting the Viper to do some garage re-maneuvering, I pushed the clutch to the floor, but the vehicle wouldn't start. Only after I put as much weight against the pedal as I could, got it to move a hair more, the car started.

    Seems...overly temperamental...but maybe that's what I've gotten myself into?

  11. #41

    Default Re: (Almost) new Viper owner, saying hi

    Prob just need to adjust the clutch switch, was an issue on the DSM's too. For some reason i thought you got a Gen II? Is that an Autoform hard top? I cant see the seam on the front edge.

  12. #42

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by TalonTSi90 View Post
    Prob just need to adjust the clutch switch, was an issue on the DSM's too. For some reason i thought you got a Gen II? Is that an Autoform hard top? I cant see the seam on the front edge.
    Alright, thanks, I'll put that on the list. Gen I for me, and that *is* an Autoform top--nice piece.

  13. #43

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by TalonTSi90 View Post
    1-4 shift skip i think.
    You are right, found a brief mention of it in the owner's manual--thanks for pointing me in the right direction.

  14. #44

    Default Re: (Almost) new Viper owner, saying hi

    Alright, so after getting over a bug, I'm finally getting around to posting some more pics--I took way too many, so this is just a sampling:

    IMG_4701.jpg

    IMG_4700.jpg

    IMG_4699.jpg

    IMG_4703.jpg

    IMG_4702.jpg

    Super excited to get this thing on the road, summer can't get here soon enough.
    Last edited by ViperDefender; 02-26-2017 at 11:43 AM.

  15. #45

    Default Re: (Almost) new Viper owner, saying hi

    Then, don't wait!

  16. #46

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by TalonTSi90 View Post
    Then, don't wait!
    Roads are too crappy!

  17. #47

    Default Re: (Almost) new Viper owner, saying hi

    Not around here, not even salt!

  18. #48

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by TalonTSi90 View Post
    Not around here, not even salt!
    I am SO jealous! Definitely one thing I don't like about Maine.

  19. #49

    Default Re: (Almost) new Viper owner, saying hi

    Was mid to low 50's I think today, perfect for swapping out the rad on my friends '03 Liberty with just a long sleeved tee over a short sleeved one. No sweating and no freezing. Was kinda nice working on a Mopar again...

  20. #50

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by TalonTSi90 View Post
    Was mid to low 50's I think today, perfect for swapping out the rad on my friends '03 Liberty with just a long sleeved tee over a short sleeved one. No sweating and no freezing. Was kinda nice working on a Mopar again...
    Yes, definitely jealous. Our temps have been climbing, which is nice, but it has left the roads an absolute mess. Actually bent a wheel a few weeks ago, the roads are so bad from frost heaves and plows.

    Maine summers are gorgeous, but the trade-off is a grueling winter.
    Last edited by ViperDefender; 02-27-2017 at 10:03 AM.

  21. #51

    Default Re: (Almost) new Viper owner, saying hi

    So as people may have noticed in my pictures from a couple posts ago, there is black shading in front of the exhaust hump (and on the front of the exhaust cover, but isn't visible in the picture I posted). At first I thought this was plastidip the previous own put on (they plastidipped the wheels), but I just saw a couple other Vipers with the exact same shading in the exactly same spots. Did some Vipers have this from the factory, or is this some sort of aftermarket thing?

  22. #52

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by ViperDefender View Post
    So as people may have noticed in my pictures from a couple posts ago, there is black shading in front of the exhaust hump (and on the front of the exhaust cover, but isn't visible in the picture I posted). At first I thought this was plastidip the previous own put on (they plastidipped the wheels), but I just saw a couple other Vipers with the exact same shading in the exactly same spots. Did some Vipers have this from the factory, or is this some sort of aftermarket thing?
    Bueller? Anyone have insight on this? Sorry to bump this post, just trying to figure out what these dark patches are, if they can be removed, etc.

  23. #53
    Viper Owner
    Join Date
    Dec 2006
    Location
    Lancaster, PA
    Posts
    1,348

    Default Re: (Almost) new Viper owner, saying hi

    Are you sure it's not clear bra material that has aged? Either way it's not factory. Unless it's painted it should be able to be remove with a heat gun and peeling.

  24. #54

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by speedracervr4 View Post
    Are you sure it's not clear bra material that has aged? Either way it's not factory. Unless it's painted it should be able to be remove with a heat gun and peeling.
    It could be, but it's weird--I see some sort of a clear coat/membrane type of layer near the edges, and the darkness itself looks somewhere between weird paint and aged discoloration.

    But thanks for the info--now I have more confidence in seeing if I can get it removed.

  25. #55

    Default Re: (Almost) new Viper owner, saying hi

    Here's a close-up of what it looks like:

    IMG_4804.jpg

  26. #56

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by ViperDefender View Post
    New question: does anyone else have to crush their clutch against the floor in order to get their Viper to start?

    When I tried starting the Viper to do some garage re-maneuvering, I pushed the clutch to the floor, but the vehicle wouldn't start. Only after I put as much weight against the pedal as I could, got it to move a hair more, the car started.

    Seems...overly temperamental...but maybe that's what I've gotten myself into?
    I had the same issue when I first bought my Viper. What I did is looped the clutch safety switch. No need to even push in the clutch when starting the car now, just make sure you are in neutral. If you want to keep the switch you have, when pressing the clutch down, move it off to the right and it will help with the starting issue.

  27. #57

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by Aaron1651 View Post
    I had the same issue when I first bought my Viper. What I did is looped the clutch safety switch. No need to even push in the clutch when starting the car now, just make sure you are in neutral. If you want to keep the switch you have, when pressing the clutch down, move it off to the right and it will help with the starting issue.
    Awesome, thank you so much for this info--this is going to be one of the first things I tackle.

  28. #58
    VCA Member
    UT/AZ

    Join Date
    Oct 1995
    Posts
    749

    Default Re: (Almost) new Viper owner, saying hi

    I would not loop the switch, keep the safty switch, to many bad things could happen, go under by the switch and ajust it so it engages sooner, you might have to bend the tab that its on but easy to do.

  29. #59

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by steve e View Post
    I would not loop the switch, keep the safty switch, to many bad things could happen, go under by the switch and ajust it so it engages sooner, you might have to bend the tab that its on but easy to do.
    Yeah, if I can find my way well enough, I'll try to adjust it/bend it accordingly.

  30. #60

    Default Re: (Almost) new Viper owner, saying hi

    Quote Originally Posted by ViperDefender View Post
    Yeah, if I can find my way well enough, I'll try to adjust it/bend it accordingly.
    IMG_4932.jpg IMG_4934.jpg

    So I got down into the footwell to try and adjust the clutch switch, but I couldn't find anything to adjust...

    Above are a couple pics. The S-shaped piece is the clutch pedal, and it is connected to the copper-colored piston/rod.

    Is the clutch switch hidden somewhere else? It's a very cramped, awkward space down there, so maybe I missed it.
    Last edited by ViperDefender; 05-12-2017 at 12:48 PM.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Similar Threads

  1. VETTE OWNER, FUTURE VIPER OWNER NEEDS YOUR HELP!!!!
    By JBS99HT in forum RT/10 and GTS Discussions
    Replies: 41
    Last Post: 07-30-2012, 02:24 PM
  2. Replies: 25
    Last Post: 04-15-2011, 11:16 AM
  3. New Viper owner - former C6 owner
    By Nine Ball in forum General Viper Discussion
    Replies: 41
    Last Post: 10-20-2007, 08:07 AM
  4. Supra Owner to Viper Owner
    By cirus in forum RT/10 and GTS Discussions
    Replies: 14
    Last Post: 04-19-2002, 06:34 AM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts